INTRODUCTION TO COMPUTER FUNDAMENTALS(ELS-133L)	SSUET/QR/122


Lab no.10
Object: Microsoft Visio for flow chart 
Microsoft Visio is a diagramming tool which allows you to create simple as well as complex diagrams according to your business needs. Visio also enables you to create detailed organization charts, floor plans, pivot diagrams, etc. It comes with many inbuilt templates which allows you to create virtually any diagram of any complexity. It can be either shape-based artwork or more complex drawing.
Description: 
History of Microsoft Visio:
· Visio originated in 1990 as a product of Shareware Corp with version 1.0 released in 1992.
· In the year 1995, the company was renamed as a Visio Corp.
· Microsoft Corporation bought it in the year 2000.
· In 2002 version 10.0 released (skipping versions 7.0 through 9.0) to align with Office release numbers.
· Visio 2007 was released on November 30, 2006, by Microsoft.
· Visio 2010 Visio 14.0 was released with Standard, Professional, Premium editions.
· Visio 2016, Visio released v 16.0 with Standard, Professional, and Office 365 versions.
· Current versions of Visio are 2019 professional and standard.
Visio File Types:
Following are important file types available with Visio:
· VSD (Visio Drawing): This file extension is associated with Visio binary file format. It is used for storing flowcharts and diagram document files.
· VSS (Visio Stencil): This file extension is associated with Microsoft Visio. The file contains smart shapes (stencils). The file is in binary Visio document format.
· VST (Visio Template): The VST file extension is associated with Microsoft Visio templates.
· VDW (Visio Web drawing): The VDW extension is associated with Microsoft Office Visio. It contains web drawing which is created in Microsoft Office Visio.

Download and Install Visio:
Notes: You require to have an active Visio license to download Visio. You need to run the "Click-to-Run" version of Microsoft Office before installing Visio. The Click-to-Run version is installed from https://www.office.com.
How to start Visio
Step 1) Click on "start" button. (Fig 10.1)
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Fig 10.1
Type Visio in a "search" box.(Fig 10.2)
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Fig 10.2

2. Click on "Visio 2013" menu. (fig 10.3)
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Fig 10.3
You can also register with Office 365 and access Visio Software Online (Fig 10.4)
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Fig 10.4
How we create diagrams:
Fig 10.5 Shows how we create diagrams
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Fig 10.5
Important components of Visio:
Here are essential components of the Visio tool:
Stencils:
Stencils contain a collection of related shapes. For example, in a workflow template, there is a stencil which contains all the workflow object shapes.


You will see stencils on the left side of the drawing page. (fig 10.6)
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Fig 10.6
The Quick Access Toolbar
The Quick Access Toolbar allows you to add often used command so that you can easily access it as when needed. (Fig 10.7)
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Fig 10.7
The Ribbon:
The Ribbon is a panel which contains functional groupings of buttons and drop-down lists organized by tabs. 
The Ribbon is designed to find commands that you need to complete a task. It includes designing pages, inserting objects onto pages, or link data with shapes. (Fig 10.8)
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Fig 10.8

The File tab (Backstage View)
The File tab provides a centralized location which is called the Backstage View. It allows you to perform various Visio file management tasks like creating, closing, sharing, saving, printing, converting to PDF, and emailing.
In Visio, the Backstage view is very important. It allows you to view document properties, removing personal information, and reducing the file size by eliminating unused items. Fig 10.9
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Fig 10.9

· Back – Go back to working drawing area.
· Info - Allows you to remove personal information, restrict permissions, reduce file size. It also helps you to check compatibility with earlier versions of Visio.
· New - Allows you to create an original drawing from a blank drawing area or using a pre-formatted template.
· Open - Open a drawing.
· Save - Save the drawing.
· Save As - Allows you to re-save as a saved drawing as a different filename or file type.
· Print - Allows you to view and print the final diagram.
· Share- Share diagrams with others.
· Export- Export your diagrams to PDF, XPS, etc.
· Account- Allows you to manage your profile.
· Options – Allows you to make proofing and language-related changes.
The Home Tab:
This is a default tab in Visio. It allows you to change font size, colour, set alignment of text, find any text, fill colour in shape, cut, copy, and paste shape as well as text.(Fig 10.10)
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Fig 10.10
The Insert Tab:
The insert tab allows you to insert illustrations, diagram parts, links, and text. (Fig 10.11)
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Fig 10.11
The Design Tab: The design tab allows you to make changes in the background, page setup, borders, color schemes, and basic layout of your drawings. (Fig 10.12)
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Fig 10.12
The Data Tab:
Using the data tab, you can link your database data to shapes, create data graphics, and insert horizontal and vertical legend. (Fig 10.13)
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Fig 10.13
The Process Tab:
You can use process tab to import and export workflow and link an existing subprocess with a shape in a larger process. Fig 10.14
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Fig 10.14
The Review Tab:
This tab offers you to add comments and check spelling. (Fig 10.15)
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Fig 10.15
The View Tab:
It allows you to personalize your view of the drawing screen. For that, various tools are given to add rulers, gridlines, guides, and page breaks.
Visio also provides a zoom button to the magnifying drawing area. Fig 10.16
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Fig 10.16
How to use Microsoft Visio Here, are steps to plan and draw a basic Visio chart:
Step 1) Decide what you're trying to accomplish and gather the suitable detail requirements to draw your diagram or chart.
Step 2) Determine which chart type best suited to illustrates the information you want to convey. In our case, we will create a login flowchart.
Step 3) In Visio, select and open the template according to your chart type. (Fig 10.17)
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Fig 10.17
Each shape represents different things, which ranges from simple rectangles, squares, ovals, and arrows to hundreds of highly specialized shapes and symbols.
Step 4) Drag and connect shapes or symbols to illustrate the items and their flow.
1. Drag terminator shape to drawing area.
2. Drag Compare2 shape.
3. Drag dynamic connector to drawing area and connect these two shapes. (Fig 10.18)
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Fig 10.18
Step 5) To add a label, go to:
1. Insert tab
2. Click on "Text Box"
3. Select horizontal Text Box (Fig 10.19)
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Fig 10.19
Click on drawing area to add label. Fig 10.20
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Fig 10.20
Step 6) Lastly, review your diagram and compare with your rough design.
Below is an example of a flowchart showing a login process. Fig 10.21
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Fig 10.21
Applications of Microsoft Visio
Here, are essential applications of Microsoft Visio:
	Usage
	Description

	Business Process Diagrams
	It is one of the most popular used of Visio. It helps you to illustrate business processes.

	Organization Charts
	Organization charts are frequently used in the diagram for your business.

	Brainstorming Diagram
	A brainstorming diagram allows you to record and develop any set of related ideas or information like new strategies for business, book outlines, travel notes, meeting minutes, etc.

	Building Plan
	You can also build the most accurate building plans in Visio. This diagram also provides an overhead view of walls, doors, windows, and furniture.

	Flowchart
	A flowchart can be used to document and analyze a process; standardize a process for efficiency and quality. It also uses for training or understanding by other parts of the organization.

	Analysis
	Visio offers focus approach to create professional Data flow diagrams (DFDs) for all types of projects.

	In business
	You can draw Business Process Modeling and Notation shortly known as (BPMN). It is targeted at participants and other stakeholders in a business process.

	In Chemical Engineering
	Visio allows you to draw a Process Flow Diagram (PFD), which is a type of flowchart that explains the relationships between various components at an industrial plant.


Best practices of using Microsoft Visio:
Following, are best practices of using Microsoft Visio:
· Start with the Visio template, which best matches the type of diagram you want to create to get your business solutions. In case the exact template isn't in the library, select the closest one.
· Use should use Visio stencils to pull in a group of shapes like basic Flowchart Shapes stencil.
· Add data to your shape by typing in the Shape Data window.
Benefits of Microsoft Visio:
Here, are benefits/cons of using Microsoft Visio.
· VISIO Provides diagramming capabilities to prepare various business engineering Software, and Database Architecture easily.
· Prepare BPMN Models, Maps, and Diagrams. Prepare Flow Charts, Capture Brain Storming discussions, etc.
· Visio Standard Online and Visio Professional both are downloadable products. You can use these products as long as they're compatible with your device.
· The tool allows you to capture the information in ways that are valuable for you and your business.
· Provide support for creating varieties of diagramming shapes.
· Visio Pro offers features like automatic updates and multiple installations.
Disadvantages of Visio:
Here, are cons/drawbacks of using MS Visio:
· The ribbon interface is not as instinctive and hides some features.
· Microsoft Visio doesn't have features, like reverse engineering for database models.
· In Visio, it's difficult to use keyboard shortcuts, add connections, copy and paste, etc.
· Download and installation process is not very smooth.
· MS Visio is expensive diagramming tool compare to the lower pricing of similar tools.
Summary:
· Important file types available with Visio are VSD (Visio Drawing), VSS (Visio Stencil), and VST (Visio Template).
· You must have an active Visio license to download Visio.
· Stencils contain a collection of related shapes.
· The Quick Access Toolbar allows you to add often used command so that you can easily access it as when needed.
· The Ribbon is a panel which contains functional groupings of buttons and drop-down lists organized by tabs.
· The File tab provides a centralized location which is called the Backstage View.
· Home tab is a default tab in Visio.
· Insert tab allows you to insert illustrations, diagram parts, links, and text.
· Insert tab allows you to make changes in the background, page setup, borders, colour schemes, and basic layout of your drawings.
· Using the data tab, you can link your database data to shapes, create data graphics, and insert horizontal and vertical legend.
· You can use this tab to import and export workflow and link an existing subprocess with a shape in a larger process.
· Review tab offers you to add comments and check the spelling.
· View tab allows you to personalize your view of the drawing screen. For that, various tools are given to add rulers, gridlines, guides, and page breaks.
Applications of Microsoft Visio are Business Process Diagrams, Organization Charts, Brainstorming Diagram, and Building Plan.
· VISIO Provides diagramming capabilities to prepare various business engineering Software, and Database Architecture easily.
· Prepare BPMN Models, Maps, and Diagrams. Prepare Flow Charts, Capture Brain Storming discussions, etc.
· The ribbon interface is not as instinctive and hides some features.
· Microsoft Visio doesn't have features, like reverse engineering for database models
Exercise
· Draw your own flow chart using shapes and connectors.
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